Welcome to Django ezTables’s documentation!

Django ezTables provides easy integration between jQuery DataTables and Django.


Django ezTables requires Python 2.6+, Django 1.4+ and Django.js 0.7.6+.


You can install Django ezTables with pip:

$ pip install django-eztables

or with easy_install:

$ easy_install django-eztables

Add djangojs and eztables to your settings.INSTALLED_APPS.


  • Datatables.net, plugins and localization integration with Django.

  • Server-side processing with a simple view supporting:
    • sorting (single and multi columns)
    • filtering with regex support (global and by column)
    • formatting using format pattern
  • Deferred loading support.

  • Twitter Bootstrap integration.


You can try the demo by cloning this repository and running the test server with the provided data:

$ python manage.py syncdb
$ python manage.py loaddata eztables/demo/fixtures/browsers.json
$ python manage.py runserver

Then open your browser to http://localhost:8000

Indices and tables

Project Versions

Table Of Contents

Next topic

Template tags

This Page